Movie Import Queue Not Working


Imported two new titles. The second of the two went, but the first one didn’t. I’ve tried it a couple of times since and it says it successfully imported, but I still don’t see it:


Edit: Timing issue in post above. Title added. Everything is working.


Hello THere : is the import queue supposed to work theses days ?

I try to import to an list and some of the films are supposely includedin an import queue??? when i click it shows films stuck since 04/2018 ??


Those films are not films, but lists. Look at the url. It’s not ttxxxxxxxx, but it’s lsxxxxxxxx. They shouldn’t stay there though.

If you’re talking about adding newly imported movies to a list, that’s still a bug that annoys me a lot. Once you’ve added a movie to iCM it takes several days before it actually shows up on a search and you can add it to a list.


I try to create an ICM list, using the By IMDb movie URL(s) tab

i then paste my IMDb URLs to the tab… pretty sure these are films as th’ey’re comming directly from an IMDB extract…

Then the ICM import crashes saying some films are not on icm yet, and theses were added to to the films to be automatiquely imported… But showing the list shows … olldies.

Next ime it happesn to me, i’ll copy paste exemples here !


This happens very often and is the most annoying bug I know.

If there is one title on your list that is not on iCM yet, the creation of the list isn’t finished. The problem is that there is a few days delay between adding the movie to iCM and being able to add them to a list. So if you want to add the list to iCM now, you have to remove the new titles from that list. Figuring out which are new is annoying, but there is a quick trick for this. Go to the page to import new titles and paste all urls into that box. When you add those, iCM tells you most titles are already on iCM, but also shows which urls are new. Then you can easily remove those and add your list without them.


This is the first time I’ve had trouble updating . Getting

Blockquote ## Whoops! * You have specified movies that have not yet been added to iCheckMovies. The missing movies have automatically been added to the movie import queue. You will automatically receive a notificaton when the movies have been imported, if you have specified so in your notification settings.

But of course I’ve no idea which of the 250 titles is the issue and don’t see anything on the import queue other than lists being imported.

Not sure what to do next and certainly can’t update the list without going title by title.


It’s probably a film that was added in the last couple of days, but hasn’t gone through the database workflow to be able to be added.
It would be nice if that page told you what film it was, though.


It’s been on the site for over a week though, so it should be addable by now, though.

Also which I just added, I guess it wasn’t on the list when you tried, since it’s 247.


Even though that’s what I was thinking, I was also just trying to do the update quickly before going on to a more important task and forgot to say “It’s probably a film that was added in the last couple of days” :blush:

Thanks for updating me - mostly I just wasn’t sure if this might be a temporary bug like the missing film poster and icon issue last week.

btw, how did you figure out which ones were the issue?


The import queue can find the films even though the search doesn’t, so it skips importing them so you don’t get a notification. The import queue is working fine. The fact that a film added almost two weeks ago can’t be added to a list could well be a related bug though. Maybe @Marijn can check.


A related bug? No, it’s been like that for a very long time and the most annoying bug on iCM for me. Every time I do a poll on icmforum or I update my monthly lists, I run into this problem. So multiple times a month I just add hundreds of titles to the import queue just to figure out which titles are new and remove those from my list-update.


Does it generally take 2 weeks though? I thought it was max 3 or 4 days.


I stopped trying, but I’ve experienced more than a week before.


I’m in the process of completely replacing the beta with next. Once that’s finished, I’ll move list updating to the beta and the problem should be resolved.